Производство фотообоев в Новосибирске. Интернет магазин фотообоев. Изготовление - один день! Каталог 10 000 изображений!
12 Май 2021

CenOS 7 — server refused our key putty

Удобная штука — ssh авторизация по ключу, но на одном из вирутальных серверов почему-то никак не авторизовалось — server refused our key putty

В CentOS логи тут /var/log/secure
Authentication refused: bad ownership or modes for directory /home/bitrix

Меняю на 700 и вуаля!

PS
Везде пишут только про права непосредственно на ~/.ssh/ — оказывается на домашнюю папку тоже нужно!

Вообще, на сервере примерно вот так оно должно выглядеть: (id_rsa.pub — публичный ключ клиенской машины)
mkdir -p ~/.ssh && cat id_rsa.pub >> ~/.ssh/authorized_keys && chmod 700 ~/.ssh && chmod 600 ~/.ssh/authorized_keys

Либо сразу с клиентской машины ssh-copy-id user@server — так ключ сразу скопируется в authorized_keys

Плюс в папке /etc/ssh/ файл настройки сервера sshd_config
Обратить внимание чтобы путь до ключей был .ssh/authorized_keys а не ~/.ssh/authorized_keys т.к. демон запускается от рута!

рубрики: NIX, Администрирование | Комментарии (0)

8 Апрель 2021

Bitrix VM CentOS — GitLab сбрасывает SSH соединение

Видимо с завтрашнего дня уже фрилансить по проекту с веб студией, писать буду реже …

Итак, продолжаю заполнять пробелы необходимые для командной работы над проектом.
Вчера тестировал GitLab — информации в любом виде куча, но у меня как обычно — не всё ладно 🙂

Регнулся на гитлабе, завёл пару учёток для совместной работы над тестовым проектом.
С рабочего компа под Win10 всё без проблем как в учебнике.
А вот под виртуальной машиной Битрикс (CentOS 7) при попытке клонировать приватный проект — даёт ошибку

ssh_exchange_identification: read: Connection reset by peer
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Порядок действий делаю как на винде — сгенерил ключ, добавил в gitlab. Пытаюсь клонировать — облом.
Читать полностью »

рубрики: NIX, Администрирование | Комментарии (0)

15 Март 2021

Меняем skin цветовую схему для Midnight Commander

Работая по ssh зачастую путаешься — то ли ты с правами root то ли под обычным пользователем, отсюда бывают накладочки.
Лично я в ssh предпочитаю работать в файловом менеджере Midnight Commander, поэтому решил для root изменить цветовую схему программы.

Все скины тут /usr/share/mc/skins/
Меняем в конфиге vi ~/.config/mc/ini
(режим вставки i (правим) потом Esc :wq — выйти и записать )
Замена в строке skin=default => skin=darkfar

Менять нужно именно внешним редактором, т.к. если это сделать в самом mc — при выходе он перезаписывает конфиг, соответственно изменения теряются

В некоторых версиях сменить можно интерактивно
Настройки -> Оформление

Но в моём CentOS 7 такой настройки не было

рубрики: NIX, Администрирование | Комментарии (0)

13 Ноябрь 2020

Linux CentOS 7 — как очистить все разделы диска — создание и удаление

Ранее в систему под управлением CentOS 7 был добавлен жестский диск, ранее использовавшийся в другом компьютере так же под управлением Linux CentOS.
Основной раздел был добавлен в систему просто посмотреть что там было (может что-то пригодиться).
Идея — выделить всё свободное место на этом жестком диске под сайт размещающийся на этом сервере http://dekorimage.ru/

Реализация плана будет такова:
1. Сбор информации — как называется диск, какие на нём разделы, что уже замаплено
2. Размапливаем что есть, удаляем разделы
3. Создаём новые

Для сбора информации можно использовать следующие команды

#ls -l /dev/ | grep sd
смотрим все девайсы, отбираем по вхождению sd

lsblk
так же смотрим девайсы, созданные разделы

df –h
информация по разделам

mount
смотрим что уже замонтировано

В моём случае имеем жестский диск
/dev/sdd
и разделы
/dev/sdd1
/dev/sdd2
/dev/sdd3

Третий раздел у меня был замонтирован в /etc/fstab — эту строчку пока закомментируем
больше никаких точек монтирования я не нашел.

Приступаем к удалению имеющихся разделов и созданию нового

parted -a optimal /dev/sdd (параметр -a optimal я добавил т.к. без него чего то там система ругалась на оптимальность распределения места, с ним не ругается)
Вводим команду mklabel
вводим метку диска — msdos или gpt (gpt поновее — я выбрал её)
далее создаём один раздел выделяя под него всё свободное пространство диска
(parted) mkpart primary 0% 100%
для проверки
(parted) align-check opt 1
(parted) align-check min 1
Если выравнивание в порядке, в ответ каждая команда вернет сообщение: «1 aligned».

Создаю файловую систему ext4
mkfs -t ext4 /dev/sdd1

монтирую новый диск
mount /dev/sdd1 /disk3

в папке /disk3 появился папка /lost+found — значит диск замонтировался

так же можно проверить наличие раздела вышеуказанными утилитами (lsblk, df -h)

размонтирую обратно
umount /disk3

Далее — вношу правки в /etc/fstab для монтируемого диска /dev/sdd1
Перезагружаюсь shutdown –r now

Всё!

рубрики: NIX, Администрирование | Комментарии (0)

6 Ноябрь 2020

Bitriv VM — Unable to load dynamic library ‘pdo_sqlite’

Для одного из проектов на виртуальной машине 1С Битрик понадобилось включить расширение pdo_sqlite
Как обычно — залез в /etc/php.d/ нашел нужный мне файл 30-pdo_sqlite.ini и переименовал 30-pdo_sqlite.ini.disabled в 30-pdo_sqlite.ini

Расширение не включилось — посмотрел phpinfo() — сам файл 30-pdo_sqlite.ini подцепляется, но сама информация по pdo_sqlite не подключилась
php —ini так же подтвердило подключение модуля

далее решил глянуть инфу с консоли
php -i | grep mysql

тут то в самом начале и обнаружилась проблема

PHP Warning: PHP Startup: Unable to load dynamic library ‘pdo_sqlite’ (tried: /usr/lib64/php/modules/pdo_sqlite (/usr/lib64/php/modules/pdo_sqlite: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/pdo_sqlite.so (/usr/lib64/php/modules/pdo_sqlite.so: undefined symbol: php_pdo_unregister_driver)) in Unknown on line 0

посмотрел — всё Ок, файл /usr/lib64/php/modules/pdo_sqlite присутствует!

В общем не буду томить, решение оказалось очень простым — включение модуля 30-pdo.ini необходимого уже для дальнейшей работы других pdo_*** модулей

рубрики: Bitrix, NIX, PHP, Администрирование | Комментарии (0)

28 Август 2020

windows 10 — после обновления драйверов пропал звук

Собственно, после обновления какого именно драйвера пропал звук я так и не понял, т.к. прошел все, которые могут отвечать за звук — нигде не было варианта откатить драйвер.

Тем не менее после того, как свежеустановленной windows 10 подключаешь интернет, через некоторое время звук просто перестаёт работать.

Причём в драйверах никаких ошибок, служба windows audio работает на ура, и вообще никаких видимых проблем и конфликтов — но звука просто нет!

Откат всех обновлений с помощью майкрософтовкой утилиты так же не дал никаких результатов 🙁

Собственно, помогло только одно решение — с помощью групповых политик, запрет использования Центра обновлений Windows при поиске драйверов.

Запускаем gpedit.msc

Административные шаблоны / Система / Управление связью через Интернет / Параметры связи через Интернет / Отключить использование Центра обновлений Windows при поиске драйверов

Мне помогло, там рядом ещё параметр что-то связанное с запросом — его тоже врубил.

Так же, если точно знать драйвера какого оборудования приводят к проблеме — можно ещё один параметр задействовать

Административные шаблоны / Система / Установка устройств / Ограничения на установку устройств / Запретить установку устройств с указанными кодами устройств

 

рубрики: Администрирование | Комментарии (0)

31 Январь 2020

Установка сертификата для https — как проверить валидность ключевых файлов?

Итак — присылает клиент приватный ключевой файл и файлы сертификата (сам сертификат, корневой и промежуточный), задание — прикрутить к nginx и настроить https
Делаю всё как обычно — нифига! nginx валит ошибку и всё тут, хоть убейся

nginx: [emerg] SSL_CTX_use_PrivateKey(«/etc/nginx/ssl/site.key») failed (SSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch)

Уже всяко разно перепробовал, всё перепроверил — нихрена!
Ну, что — думаю нужно как то проверить валидность этих двух файлов, а точнее проверить их на совместимость.

Быстренько загуглил и вот решение:

openssl x509 -noout -text -in [path of public key]
openssl rsa -noout -text -in [path of private key]

Если поля «MODULUS» и «PUBLIC EXPONENT» совпадают для каждого из ключей, то и сами ключи соответствуют паре.

В случае, если поля не совпадают, вероятнее всего, Вы используете неверный приватный ключ.
Решений здесь может быть несколько, вот, некоторые из них:
1. Попробовать найти верный приватный ключ и повторить попытку;
2. Сгенерировать новый CSR запрос с новым приватным ключом и отправить запрос на перевыпуск сертификата.

После выявления несоответствия обратился к заказчику и выяснилось, что у него оказывается два ключевых файла!
Почему я так и не понял — что он там натыкал и как, но второй конечно же подошел и всё завелось!

минус два часа рабочего времени из за косорукости заказчика 🙁

рубрики: NIX, Администрирование | Комментарии (0)

26 Ноябрь 2019

OSPF — динамическая маршрутизация на Mikrotik за 5 минут

Являясь официальным системным администратором в одной коммерческой организации я работаю с сетями на маршутизаторах Mikrotik.
Недавно решил навести порядок в сети и довести до ума работу по резервным каналам.
Сам с лёту разрулить не смог — обратился за помощью на форумы и собственно, нашел помощь на www.cyberforum.ru
Для решения проблемы создал две ветки Создал две ветки PPTP через запасной канал и
Одновременная маршрутизация через разные каналы.
В результате общения в которых пришел к выводу поднятия OSPF на подчинённых мне микротах.
Собственно, технические детали в последней ветке.
Если кратко, то я в шоке! Технология очень удобная в реализации и очень быстрая в настройке!
Настраивается в 3 пункта — добавляем экземляр, интерфейсы, сети — всё!

Пример настройки моего домашнего МТ с GRE туннелями в офис и на склад.
/routing ospf instance
set [ find default=yes ] router-id=1.1.1.3
/routing ospf interface
add interface=gre-office network-type=point-to-point
add interface=gre-cargo network-type=point-to-point
add interface=bridge88 network-type=broadcast passive=yes
/routing ospf network
add area=backbone network=192.168.15.0/30
add area=backbone network=192.168.16.0/30
add area=backbone network=192.168.88.0/30

Аналогичные настройки делаем в офисе и на складе — все необходимые маршруты будут созданы динамически!

рубрики: Администрирование | Комментарии (0)

8 Ноябрь 2019

Как не нужно делать почтовые рассылки

Пост наверно лучше было назвать «как я ушатал почту домена genteka.ru 🙁
Собственно, хотел сделать рассылку с предложением хорошей скидки по клиентской базе, вернее сделал рассылку — и попал «ногами в жир».
Ну что тут говорить — спамить нельзя 🙂 и даже когда с технической стороны всё настроишь правильно все почтовые сервисы ОЧЕНЬ быстро распознают рассылку и присваивают тебе ярлык спамера.
Теперь с почты домена даже одно письмо написанное собственноручно определяется спамом 🙁 что делать — даже не знаю, пока жду 24 часа блокировки на mail.yandex.ru, далее наверное буду писать в саппорт.
Перед рассылкой нужно было хотя бы погуглить на эту тему и ознакомиться с рекомендациями и требованиями к честным рассылками.

Сейчас для мониторинга бедственного положения домена в почтовом плане, добавил его в postmaster от Гугла — бум мониторить и как то пробовать вытащить его из ямы 🙁

Из плюсов всего происшедшего — нашел рабочий скрипт c smtp авторизацией, который можно использовать для небольших рассылок.
Настроил все проверки (DKIM, PTR, SPF) для рассылки непосредственно скриптом с хостинга домена (опять же в небольших количествах).
Ну и нашел доку по «честным рассылками» — в этом направлении ещё нужно будет поработать!

рубрики: Администрирование | Комментарии (0)

20 Июнь 2019

Обнаружение и ликвидация DDOS на Windows 2008 Server — lsass.exe исходящий трафик с 389 порта

Волею судеб предоставляю я виртуальных хостинг для базе Windows 2008 Server R2 — как решение с удалённым сервером одним моим знакомым — собственно, его и приходится админить.
Сегодня приходит мессага с дата центра — канал с серваком забивает 100 мегабитный канал по самые уши — разбирайтесь!
На самом деле хвалиться не чем, т.к. такой херни вообще по идее быть не должно, но факт остаётся фактом.

Честно говоря в плане администрирования Винды открытой жопой торчащей в интернет я вообще слаб, даже не знаю нормальных антивирусов с хорошим настраиваемым фаерволом для Виндовс серверов 🙁
Ладно, к сути — канал забит, чего делать ?!
Стоит антивирь 360 Total Security халявная версия, который в плане сетевой защиты оказался полным нулём. Встроенный брандмауер тоже оказался бессильным.
Очень сильно выручил встроенный монитор ресурсов
Запускается так
perfmon /res
С помощью которого я определил, что исходящий трафик генерит lsass.exe с локального порта 389
Сделал блокирующее правило, ребутнул сервак и тьфу тьфу — вроде тишина пока.
Далее ставим все обновления (почему то служба была выключена), и на ночь запущу проверку cureit — может чего найдёт.

рубрики: security, Администрирование | Комментарии (0)