.
Место для Вашей рекламы
8 Апрель 2014

Виртуальная машина Битрикс «не видит» сетевой интерфейс eth0

posted in Bitrix, Администрирование |

Не так давно использую технологию виртуализации серверов, в качестве самой виртуальной машины испльзую готовую BitrixVM.
Собственно, всё шло хорошо — тут захотел я перетащить виртуалку с одного физического сервера на другой.
Перенёс не всю папку с виртуалкой (моя ошибка), а только vmdk — жестский диск.
При запуске виртуалки — ошибка
eth0 error fetching interface information device not found
далее грузится
смотрю ifconfig — сетевых интерфейсов нет вообще! (хотя казалось бы что такого — виртуалку перетащил, куда пропала сеть ?!)

Вопрос найден довольно быстро, но себе в блог, я решил зарепостить.

Такое возникает при смене MAC адреса или если заменена сетевая карта. Имена сетевых устройств к MAC адресам привязывает udev в файле /etc/udev/rules.d/*_persistent-net.rules Этот файл можно отредактировать вписав новый MAC адрес или удалить. При старте udev он будет создан заново.

P.S.
Ещё почему-то все сетевые настройки послетели — это решается быстро, правкой /ets/syscinfig/network-scripts/ifcfg-eth0

У нас один комментарий на запись “Виртуальная машина Битрикс «не видит» сетевой интерфейс eth0”

Почему бы Вам не высказать своем мнение! Позвольте нам узнать, что Вы думаете...

  1. 1 On 21.02.2015, Александр said:

    добрый день! столкнулся с такой же проблемой (переносил экспортом) — нет сетефой. Вписал в новой вирт.машине МАС от старой — все вернулось на свои места. странно это)

Оставить комментарий

Яндекс.Метрика