.
26 апреля 2010

Установка Zend Optimizer на FreeBSD с PHP 5.x.x

posted in NIX, Программирование |

Очередная микро ремарка о подводном камне при установке Zend Optimizer в ОС FreeBSD для PHP 5й версии.

Итак, понизив версию до 5.2.12_2, и имея кое какие скриптики «замотанные» зендом, мне необходимо было установить Zend Optimizer.

Казалось бы всё просто

cd /usr/ports/devel/ZendOptimizer

make install clean

Да не тут то было

===>  ZendOptimizer-3.3.0.a cannot install: doesn't work with PHP version : 5 (Doesn't support  PHP 5).
*** Error code 1

И это при том, что порты я перед установкой ПО обновил по последние версии!

Решение оказалось не сложным — установка пакета напрямую командой pkg_add

pkg_add -r ZendOptimizer

смотрим что получилось:

Проверяем в установленных в системе пакетах pkg_info | grep Zend

Проверяем в установленных в PHP модулях php -m

Рестартим индейца apachectl restart и проверяем внешним запросом на скрипт содержащий код <?php phpinfo (); ?> на предмет содержания строчки «with Zend Optimizer v3.3.0, Copyright © 1998—2007, by Zend Technologies»

Вуаля !

Яндекс.Метрика